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Unit-1 

Definition of a Computer 

A computer is an electronic device that processes data and performs tasks based 

on a set of instructions (programs). It can store, retrieve, and manipulate data to 

produce meaningful results. Computers are versatile, high-speed devices used 

for a wide range of applications, including calculations, communication, 

automation, and entertainment. 

 

Characteristics of a Computer 

1. Speed: 

o Computers can process data and execute instructions at incredible 

speeds, measured in fractions of a second (microseconds, 

nanoseconds). 

2. Accuracy: 

o They perform calculations and execute tasks with a high degree of 

precision. Errors typically occur only due to human input or 

programming flaws. 

3. Automation: 

o Once programmed, computers can perform a sequence of tasks 

automatically without requiring additional human intervention. 

4. Versatility: 

o Computers can perform a variety of tasks ranging from simple 

calculations to complex simulations, provided they are 

programmed accordingly. 

5. Storage: 

o Computers can store vast amounts of data and retrieve it quickly. 

They have primary (RAM) and secondary (hard drives, SSDs) storage 

systems for data handling. 

6. Connectivity: 



o Modern computers can connect to other devices and networks, 

enabling communication and data sharing across the globe (e.g., via 

the Internet). 

7. Multitasking: 

o They can perform multiple tasks simultaneously, such as running 

multiple programs or processes concurrently. 

8. Diligence: 

o Unlike humans, computers do not suffer from fatigue or lack of 

concentration. They can operate continuously without loss of 

efficiency. 

9. Reprogramming: 

o Computers can be reprogrammed to perform different tasks by 

changing the software or instructions they follow. 

10. Data Processing: 

o They process data in raw form and produce meaningful output 

(information), making them essential tools in decision-making. 

 

Limitations of a Computer 

1. No Intelligence: 

o Computers cannot think, reason, or make decisions on their own. 

They rely entirely on pre-programmed instructions and human 

input. 

2. Lack of Emotions: 

o Computers cannot understand or express emotions, which limits 

their ability to handle tasks requiring empathy or subjective 

judgment. 

3. Dependence on Input: 

o They are entirely dependent on humans for input and instructions. 

Incorrect or incomplete input leads to incorrect output (GIGO: 

Garbage In, Garbage Out). 



4. High Initial Cost: 

o The acquisition, setup, and maintenance of advanced computers 

can be expensive, especially for high-performance systems. 

5. No Self-Healing: 

o Computers cannot fix their own software or hardware issues. 

Human intervention is required for troubleshooting and 

maintenance. 

6. Vulnerability: 

o Computers are susceptible to cyberattacks, viruses, malware, and 

unauthorized access, which can compromise data security. 

7. Environmental Impact: 

o The manufacturing, operation, and disposal of computers 

contribute to electronic waste and environmental concerns. 

8. Limited Creativity: 

o Computers cannot generate original ideas or creative content 

without specific programming or guidance. 

9. Resource Dependency: 

o They require electricity, software, and hardware compatibility to 

function, limiting their usability in resource-constrained 

environments. 

 

Digital and Analog Computers 

Digital Computers 

Digital computers process data in binary format (0s and 1s). They are used for 

calculations, data processing, and automation in various fields such as business, 

education, and engineering. 

Features: 

1. Operate using discrete signals (binary). 

2. High accuracy and speed. 



3. Used for tasks like data analysis, simulations, and gaming. 

Analog Computers 

Analog computers process continuous data, such as temperature, speed, or 

pressure, and are used in fields like scientific research and industrial control 

systems. 

Features: 

1. Operate using continuous signals. 

2. Less accurate compared to digital computers. 

3. Used for real-time simulations and modeling. 

 

Major Components of a Digital Computer 

A digital computer consists of hardware and software components that work 

together to perform tasks. Major components include: 

1. Central Processing Unit (CPU): 

o The "brain" of the computer that performs calculations, processes 

data, and executes instructions. 

o Composed of the Arithmetic Logic Unit (ALU), Control Unit (CU), 

and Registers. 

2. Memory: 

o Stores data and instructions for processing. 

o Types: 

▪ Primary Memory (RAM, ROM): Temporary storage. 

▪ Secondary Memory (Hard drives, SSDs): Long-term storage. 

3. Input Devices: 

o Devices that allow data entry into the computer (e.g., keyboard, 

mouse). 

4. Output Devices: 



o Devices that display or output data from the computer (e.g., 

monitor, printer). 

5. Storage Devices: 

o Devices for data storage (e.g., hard drives, USB drives). 

6. Motherboard: 

o The main circuit board that connects and facilitates communication 

between all components. 

7. Power Supply Unit (PSU): 

o Converts electrical power to a usable form for the computer's 

components. 

8. Communication Devices: 

o Enable data transfer (e.g., network cards, modems). 

 

Hardware, Software, Firmware, Middleware, Freeware 

1. Hardware 

• Definition: The physical components of a computer system that can be 

touched and seen. 

• Examples: CPU, monitor, keyboard, mouse, hard drives. 

2. Software 

• Definition: The set of instructions or programs that tell the hardware what 

to do. 

• Types: 

o System Software: Operating systems like Windows, Linux. 

o Application Software: Programs like MS Word, Photoshop. 

o Utility Software: Antivirus, disk cleanup tools. 

3. Firmware 



• Definition: A type of software embedded into hardware to control its 

operation. It is semi-permanent and resides in non-volatile memory like 

ROM or flash. 

• Examples: 

o BIOS/UEFI in a computer. 

o Firmware in printers, routers, and smart devices. 

4. Middleware 

• Definition: Software that acts as a bridge between different applications 

or between applications and operating systems, facilitating 

communication and data exchange. 

• Examples: 

o Message-oriented middleware (MOM) for real-time messaging. 

o Database middleware for accessing databases. 

5. Freeware 

• Definition: Software that is free to use but is copyrighted. Users cannot 

modify or redistribute it without the creator's permission. 

• Examples: 

o Skype, Adobe Acrobat Reader. 

 

 

 

 

 

 

 

 

 



Unit-2 

Number Systems in Computing 

Number systems are used to represent and manipulate numbers in various 

bases. In computing, four main number systems are commonly used: Decimal, 

Binary, Octal, and Hexadecimal. 

 

1. Decimal Number System 

• Base: 10 

• Digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 

• Usage: It is the standard number system used in everyday life. 

• Representation: Each digit's place value is a power of 10 (e.g., 

134=1×102+3×101+4×100134 = 1 \times 10^2 + 3 \times 10^1 + 4 \times 

10^0134=1×102+3×101+4×100). 

 

2. Binary Number System 

• Base: 2 

• Digits: 0, 1 

• Usage: Fundamental in computers and digital systems, as they operate 

using electrical signals (on/off or 1/0). 

• Representation: Each digit's place value is a power of 2 (e.g., 

101=1×22+0×21+1×20=5101 = 1 \times 2^2 + 0 \times 2^1 + 1 \times 2^0 

= 5101=1×22+0×21+1×20=5). 

 

3. Octal Number System 

• Base: 8 

• Digits: 0, 1, 2, 3, 4, 5, 6, 7 

• Usage: Sometimes used in digital electronics and shorthand for binary 

numbers. 



• Representation: Each digit's place value is a power of 8 (e.g., 

57=5×81+7×80=4757 = 5 \times 8^1 + 7 \times 8^0 = 4757=5×81+7×80=47 

in decimal). 

 

4. Hexadecimal Number System 

• Base: 16 

• Digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A (10), B (11), C (12), D (13), E (14), F (15) 

• Usage: Widely used in programming, memory addressing, and 

representing colors in HTML. 

• Representation: Each digit's place value is a power of 16 (e.g., 

1A3=1×162+10×161+3×160=4191A3 = 1 \times 16^2 + 10 \times 16^1 + 3 

\times 16^0 = 4191A3=1×162+10×161+3×160=419 in decimal). 

 

Number System Conversions 

1. Decimal to Other Systems 

• Decimal to Binary: Divide the number by 2 and record the remainders. 

Write the remainders in reverse order. 

o Example: 251025_{10}2510 → 11001211001_2110012 

• Decimal to Octal: Divide the number by 8 and record the remainders. 

Write the remainders in reverse order. 

o Example: 251025_{10}2510 → 31831_8318 

• Decimal to Hexadecimal: Divide the number by 16 and record the 

remainders. Use digits (0-9) and letters (A-F). 

o Example: 251025_{10}2510 → 191619_{16}1916 

2. Binary to Other Systems 

• Binary to Decimal: Multiply each binary digit by 2n2^n2n, where nnn is 

the position from the right, starting at 0. 

o Example: 110012=1×24+1×23+0×22+0×21+1×20=251011001_2 = 1 

\times 2^4 + 1 \times 2^3 + 0 \times 2^2 + 0 \times 2^1 + 1 \times 

2^0 = 25_{10}110012=1×24+1×23+0×22+0×21+1×20=2510 



• Binary to Octal: Group binary digits in sets of 3 from right to left and 

convert each group to octal. 

o Example: 11001211001_2110012 → 011001011 001011001 → 

31831_8318 

• Binary to Hexadecimal: Group binary digits in sets of 4 from right to left 

and convert each group to hexadecimal. 

o Example: 11001211001_2110012 → 000110010001 100100011001 

→ 191619_{16}1916 

3. Octal and Hexadecimal 

• Octal to Binary: Convert each octal digit to its 3-bit binary equivalent. 

o Example: 31831_8318 → 0110012=110012011 001_2 = 

11001_20110012=110012 

• Hexadecimal to Binary: Convert each hexadecimal digit to its 4-bit binary 

equivalent. 

o Example: 191619_{16}1916 → 0001100120001 1001_2000110012 

 

Binary Addition 

Binary addition follows these rules: 

1. 0+0=00 + 0 = 00+0=0 

2. 0+1=10 + 1 = 10+1=1 

3. 1+0=11 + 0 = 11+0=1 

4. 1+1=101 + 1 = 101+1=10 (0 carry 1) 

Example: 

Add 101121011_210112 and 110121101_211012: 

markdown 

  1011 

+ 1101 

------- 



 11000 

Binary Subtraction 

Binary subtraction uses these rules: 

1. 0−0=00 - 0 = 00−0=0 

2. 1−0=11 - 0 = 11−0=1 

3. 1−1=01 - 1 = 01−1=0 

4. 0−1=10 - 1 = 10−1=1 (borrow 1 from the next higher bit) 

Example: 

Subtract 110121101_211012 from 10111210111_2101112: 

markdown 

   10111 

 -  01101 

 --------- 

    01010 

 

Uses of Computers in Offices and Banks 

1. In Offices 

Computers play a pivotal role in modern offices, improving efficiency and 

productivity. Key uses include: 

• Documentation: Creating, editing, and storing documents using word 

processors. 

• Communication: Email, video conferencing, and instant messaging for 

internal and external communication. 

• Data Storage and Management: Organizing and securing data using 

spreadsheets, databases, and cloud storage. 

• Automation: Automating repetitive tasks like payroll, attendance, and 

inventory management. 



• Presentation: Creating visually appealing presentations for meetings and 

reports. 

• Desktop Publishing: Designing promotional materials such as brochures 

and newsletters. 

• Project Management: Using tools like MS Project or Trello to manage 

tasks, deadlines, and collaboration. 

2. In Banks 

Computers are essential in banking for managing accounts, transactions, and 

customer interactions. Key applications include: 

• Account Management: Tracking deposits, withdrawals, and balances 

digitally. 

• Online Banking: Enabling customers to conduct transactions, pay bills, 

and check balances remotely. 

• ATMs: Facilitating cash withdrawals, balance inquiries, and fund transfers. 

• Loan Processing: Automating loan application evaluations and approvals. 

• Security: Enhancing transaction security through encryption and fraud 

detection systems. 

• Customer Relationship Management (CRM): Managing customer data 

and improving service quality. 

 

Computer Applications in Business, Education, and Healthcare 

1. In Business 

Computers streamline operations, improve decision-making, and enhance 

customer experiences. Applications include: 

• Accounting and Finance: Software like Tally and QuickBooks for financial 

tracking and reporting. 

• Marketing: Digital advertising, social media management, and customer 

analytics. 

• E-Commerce: Online sales platforms and customer relationship 

management. 



• Inventory Management: Automating stock tracking and supply chain 

management. 

• Human Resources: Managing employee records, payroll, and recruitment 

processes. 

2. In Education 

Computers have transformed education by facilitating teaching, learning, and 

administrative tasks: 

• E-Learning: Online courses and virtual classrooms (e.g., Zoom, Google 

Classroom). 

• Research: Access to digital libraries, journals, and research databases. 

• Interactive Learning: Multimedia tools for interactive and engaging 

lessons. 

• Administration: Managing student records, attendance, and examination 

results. 

• Skill Development: Teaching coding, software usage, and other technical 

skills. 

3. In Healthcare 

Computers improve patient care, streamline operations, and enhance research 

in healthcare: 

• Electronic Health Records (EHR): Digital storage and retrieval of patient 

records. 

• Diagnostics: Imaging systems like CT scans, MRIs, and X-rays. 

• Telemedicine: Remote consultations and monitoring through video 

conferencing and IoT devices. 

• Hospital Management Systems: Automating appointment scheduling, 

billing, and inventory management. 

• Pharmaceuticals: Drug research and development using simulation and 

computational analysis. 

• Training and Research: Providing tools for medical simulations and access 

to global research. 



Unit-3 

Microsoft Word: Features and Functionalities 

1. Creating and Editing Documents in MS Word 

• Creating: 

o Open MS Word and select a blank document or a template. 

o Type or insert text, images, or objects into the document. 

• Editing: 

o Select text to cut, copy, paste, or delete. 

o Use the "Undo" and "Redo" options for quick changes. 

o Find and replace words using Ctrl + H or the "Find" tool. 

 

2. Formatting a Document in MS Word 

Formatting enhances the appearance and readability of a document: 

• Text Formatting: 

o Change font type, size, and color from the "Font" group. 

o Apply bold, italics, underline, or strikethrough styles. 

• Paragraph Formatting: 

o Adjust alignment (left, center, right, justified). 

o Modify line spacing and add bullet points or numbered lists. 

• Styles: 

o Use predefined styles from the "Styles" pane for consistency. 

• Page Layout: 

o Set margins, orientation (portrait/landscape), and size from the 

"Layout" tab. 

 

3. AutoText and AutoCorrect in MS Word 



• AutoText: 

o Store frequently used text or graphics for quick insertion. 

o Create AutoText entries via "Insert" > "Quick Parts" > "Save 

Selection to Quick Part Gallery." 

• AutoCorrect: 

o Automatically corrects typos and common spelling errors. 

o Configure via "File" > "Options" > "Proofing" > "AutoCorrect 

Options." 

 

4. Spelling and Grammar Tool in MS Word 

• Purpose: 

o Identifies and corrects spelling and grammatical errors. 

• Using the Tool: 

o Click on "Review" > "Spelling & Grammar" or press F7. 

o Review suggestions and accept, ignore, or customize changes. 

• Real-time Suggestions: 

o Red wavy lines for spelling errors, blue for grammar issues. 

 

5. Document Dictionary in MS Word 

• Definition: 

o The dictionary helps verify and suggest correct spellings. 

• Adding Words: 

o Right-click on a flagged word and select "Add to Dictionary." 

• Custom Dictionaries: 

o Manage dictionaries via "File" > "Options" > "Proofing" > "Custom 

Dictionaries." 

 



6. Page Formatting and Bookmark in MS Word 

• Page Formatting: 

o Headers and Footers: Insert from the "Insert" tab for consistent 

content on each page. 

o Page Numbers: Add page numbers via "Insert" > "Page Number." 

o Page Breaks: Insert breaks for content organization (e.g., Ctrl + 

Enter). 

• Bookmarks: 

o Purpose: Mark specific locations in the document for quick 

navigation. 

o Usage: "Insert" > "Bookmark," name the bookmark, and use "Go 

To" to jump to it. 

o  

7. Advanced Features of MS Word 

• Track Changes: 

o Collaborate by tracking edits via "Review" > "Track Changes." 

• Comments: 

o Add comments for suggestions or feedback. 

• Tables and Charts: 

o Insert tables and charts for structured data presentation. 

• Hyperlinks: 

o Create links to websites, documents, or sections within the file. 

• Macros: 

o Automate repetitive tasks by recording macros via "View" > 

"Macros." 

o  

8. Mail Merge and Printing in MS Word 

• Mail Merge: 



o Automate sending personalized letters, labels, or emails. 

o Steps: 

1. Open "Mailings" tab > Start Mail Merge. 

2. Select recipients from a file (Excel or database). 

3. Insert merge fields (e.g., name, address). 

4. Preview results and finish by merging to print or email. 

• Printing: 

o "File" > "Print" to access the printing menu. 

o Configure options like page range, orientation, and copies. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Unit-4 

Introduction to MS Excel 

Microsoft Excel is a powerful spreadsheet application used for data analysis, 

organization, and visualization. It is widely used in business, education, and 

personal finance to handle calculations, manage data, and create reports. 

Key Features: 

• Spreadsheet Structure: Composed of rows (numbered) and columns 

(lettered), forming cells (e.g., A1, B2). 

• Data Management: Enter, edit, and organize data effectively. 

• Formulas and Functions: Automate calculations and perform complex 

analyses. 

• Visualization: Create charts and graphs for data representation. 

• Customizable: Use formatting tools to make spreadsheets user-friendly 

and visually appealing. 

 

Creating and Editing a Worksheet 

1. Creating a Worksheet: 

o Open MS Excel and select a blank workbook. 

o Use cells to input data like text, numbers, or formulas. 

o Rename worksheets by double-clicking the tab (default: Sheet1, 

Sheet2). 

2. Editing a Worksheet: 

o Insert/Delete Rows and Columns: Right-click on the row/column 

header and choose the desired option. 

o Resize: Adjust row height and column width by dragging the 

borders. 

o Copy/Cut/Paste: Use Ctrl + C, Ctrl + X, and Ctrl + V for quick editing. 

o Undo/Redo: Use Ctrl + Z and Ctrl + Y. 



Formatting and Essential Operations 

1. Formatting: 

o Text and Numbers: Change font, size, color, and style (bold, italic, 

underline) from the "Home" tab. 

o Cell Borders and Shading: Add borders and background colors for 

better data organization. 

o Number Formats: Set formats for currency, percentages, or dates. 

o Alignment: Align text horizontally or vertically and wrap text within 

cells. 

2. Essential Operations: 

o Sort and Filter: Organize data by specific criteria from the "Data" 

tab. 

o Find and Replace: Locate and replace data using Ctrl + F and Ctrl + 

H. 

o Freeze Panes: Keep headers visible while scrolling (View > Freeze 

Panes). 

o Conditional Formatting: Highlight cells based on conditions (e.g., 

values above a certain threshold). 

 

Formulas and Functions 

1. Formulas: 

o Start with an = sign followed by the operation. 

o Example: =A1 + B1 adds the values in cells A1 and B1. 

2. Common Functions: 

o SUM: Adds a range of values (=SUM(A1:A5)). 

o AVERAGE: Calculates the average of values (=AVERAGE(B1:B5)). 

o IF: Performs logical tests (=IF(A1>10, "Yes", "No")). 

o VLOOKUP: Searches for values in a table (=VLOOKUP(lookup_value, 

table_array, col_index, range_lookup)). 



o COUNT: Counts numeric entries in a range (=COUNT(A1:A10)). 

o LEN: Counts the number of characters in a cell (=LEN(A1)). 

3. Cell Referencing: 

o Relative Reference: Adjusts based on cell position (A1). 

o Absolute Reference: Fixed reference using $ ($A$1). 

o Mixed Reference: Combination of fixed and relative (A$1 or $A1). 

 

Charts 

1. Purpose: 

o Visualize data for easier interpretation and decision-making. 

2. Creating a Chart: 

o Highlight the data range. 

o Go to the "Insert" tab and select a chart type (e.g., bar, line, pie). 

3. Types of Charts: 

o Column/Bar Chart: Compare categories or track changes over time. 

o Line Chart: Display trends. 

o Pie Chart: Show proportions of a whole. 

o Scatter Plot: Analyze relationships between variables. 

4. Customizing Charts: 

o Add titles, legends, and data labels. 

o Format axes, change colors, and modify chart styles. 

 

Microsoft PowerPoint: Creating and Enhancing Presentations 

Microsoft PowerPoint is a widely-used tool for creating dynamic and visually 

appealing presentations. Its features allow users to convey information 

effectively through slides, visuals, animations, and sounds. 

 



1. Presentations in MS PowerPoint 

A presentation in PowerPoint is a series of slides that may include text, images, 

charts, animations, and multimedia. It is used for: 

• Business reports and proposals. 

• Educational lessons and lectures. 

• Marketing and sales pitches. 

• Personal or creative storytelling. 

 

2. Creating, Manipulating, and Enhancing Slides 

Creating Slides: 

• Open PowerPoint and choose a template or a blank presentation. 

• Click "New Slide" in the "Home" tab to add slides. 

• Select layouts like title slides, content slides, or blank slides as needed. 

Manipulating Slides: 

• Reorder Slides: Drag slides in the thumbnail pane on the left. 

• Duplicate Slides: Right-click a slide and choose "Duplicate Slide." 

• Delete Slides: Right-click a slide and select "Delete Slide." 

Enhancing Slides: 

• Background Design: Use the "Design" tab to apply themes and 

backgrounds. 

• Text Formatting: Customize fonts, colors, and styles from the "Home" tab. 

• Inserting Media: Add images, videos, or audio from the "Insert" tab. 

• Transitions: Apply transitions between slides using the "Transitions" tab. 

 

3. Organizational Charts 

Purpose: 



Organizational charts visually represent hierarchies or relationships in an 

organization or process. 

Creating an Organizational Chart: 

1. Go to the "Insert" tab and click "SmartArt." 

2. Select "Hierarchy" and choose a chart style. 

3. Add text to the chart boxes and adjust the layout using the "SmartArt 

Tools" tab. 

 

4. Excel Charts in PowerPoint 

Embedding Charts: 

1. Create a chart in Excel. 

2. Copy the chart (Ctrl + C) and paste it into PowerPoint (Ctrl + V). 

3. Choose whether to link the chart to the Excel file (updates with changes) 

or embed it (static data). 

Inserting a Chart Directly in PowerPoint: 

1. Go to "Insert" > "Chart." 

2. Choose a chart type (e.g., bar, line, pie). 

3. Edit the chart data directly in the pop-up Excel window. 

 

5. WordArt 

Purpose: 

WordArt enhances text with decorative styles and effects. 

Adding WordArt: 

1. Go to the "Insert" tab and click "WordArt." 

2. Choose a style and type your text. 

3. Use the "Format" tab to customize the color, shape, shadow, and effects. 

 



6. Layering Art Objects 

Definition: 

Layering involves placing multiple objects (e.g., images, text boxes, shapes) on 

top of each other. 

Managing Layers: 

1. Select an object. 

2. Use the "Arrange" option in the "Home" or "Format" tab. 

3. Options include: 

o Bring to Front: Moves an object above others. 

o Send to Back: Moves an object below others. 

o Align: Align multiple objects for a clean layout. 

o Group: Combine multiple objects into one for easier manipulation. 

o  

7. Animations and Sounds 

Animations: 

Animations add movement to slide elements to emphasize content or create 

interest. 

1. Select the object (text, image, etc.) you want to animate. 

2. Go to the "Animations" tab and choose an effect (e.g., Fade, Fly In, 

Bounce). 

3. Use the "Animation Pane" to control the sequence, duration, and triggers. 

Sounds: 

Sounds enhance presentations by adding audio effects or background music. 

1. Go to the "Insert" tab > "Audio." 

2. Choose "Audio on My PC" or "Record Audio." 

3. Control playback using the "Playback" tab (e.g., start on click, loop until 

stopped). 


